Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-13933 Client Policies
  3. KEYCLOAK-18113

Refactor some executor/condition provider IDs

    XMLWordPrintable

    Details

    • Type: Sub-task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 14.0.0
    • Component/s: None
    • Labels:
    • Docs QE Status:
      NEW
    • QE Status:
      NEW

      Description

      Based on the discussion within Keycloak team, one of the feedback for client policies was related to executor/condition names. It was suggested to remove suffix like "-condition" and "-executor" from the provider IDs to make JSON configuration more clear. Besides that, I've tried to refactor a bit more to make provider IDs hopefully more descriptive and shorter and I've renamed some classes accordingly (EG. "ClientUpdater*" instead of "ClientUpdate*" as some conditions are related to "updater" who is updating client etc).

        Attachments

          Activity

            People

            Assignee:
            mposolda Marek Posolda
            Reporter:
            mposolda Marek Posolda
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: