Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-17205

[REL] Admin console is not working after upgrading from 11.0.3

    XMLWordPrintable

    Details

    • Steps to Reproduce:
      Hide
      1. Using KC 11.0.3, create several realms
      2. Upgrade to 12.0.1
      3. Log in into admin console
      4. Select any of created realms

      2nd approach

      1. Deploy KC 12.0.1
      2. Log into admin console
      3. Create realm
      4. rename realm
      5. refresh page

      Expected: realm settings are opened

      Actual: 404 not found is shown

      Show
      Using KC 11.0.3, create several realms Upgrade to 12.0.1 Log in into admin console Select any of created realms 2nd approach Deploy KC 12.0.1 Log into admin console Create realm rename realm refresh page Expected: realm settings are opened Actual: 404 not found is shown
    • Docs QE Status:
      NEW
    • QE Status:
      NEW

      Description

      After keycloak upgrade, Admin console is not working properly

      Realm locale strings are requested using realmId, but query is done using realm name

      Query from dev tools: /auth/admin/realms/4082ff3e-f087-4f6f-b082-579482805aef/localization/en

      Query in KC debug log
      select
        realmentit0_.ID as col_0_0_
      from
        public.REALM realmentit0_
      where
        realmentit0_.NAME=?
       
      Note that condition is based on realm name, but realm id is passed instead

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              ssilvert Stan Silvert
              Reporter:
              betalb Vitalii Ishchenko
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: