Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-12796

IdP users no longer auto-created as local users after upgrade from 6.0.1 or 7.0.1 to 8.0.1

    XMLWordPrintable

    Details

    • Steps to Reproduce:
      Hide

      Upgrade from 6.0.1 to 8.0.1 and try logging in using an IdP.

      Show
      Upgrade from 6.0.1 to 8.0.1 and try logging in using an IdP.
    • Docs QE Status:
      NEW
    • QE Status:
      NEW

      Description

      After upgrading from Keycloak 6.0.1 to 8.0.1, users logging in via our Google IdP no longer automatically have their local accounts created.

      Users who logged in previously can still log in fine, as their keycloak accounts exist and are properly matched.

      New users get presented with the whole Google login box, but after logging in they simply get a Keycloak "username or password incorrect" screen. Their local account is not created.

      In the Keycloak logs I can only see the failed authentication attempts. No errors prior to that about trying to create a user account.

      The "Account Linking Only" switch is toggled to OFF - as it was in 6.0.1 - no settings have changed.

        Attachments

          Activity

            People

            Assignee:
            sebastian.laskawiec Sebastian Ɓaskawiec
            Reporter:
            gboor Gerard Boor (Inactive)
            Votes:
            3 Vote for this issue
            Watchers:
            10 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: