Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-12770

keycloak-connect NPM package does not contain TypeScript type definitions

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate Issue
    • Affects Version/s: 8.0.0, 8.0.1
    • Fix Version/s: 9.0.0
    • Component/s: Adapter - Node.js
    • Labels:
      None
    • Steps to Reproduce:
      Hide
      mkdir test && cd test && npm install keycloak-connect && cat node_modules/keycloak-connect/keycloak.d.ts
      
      Show
      mkdir test && cd test && npm install keycloak-connect && cat node_modules/keycloak-connect/keycloak.d.ts
    • Docs QE Status:
      NEW
    • QE Status:
      NEW

      Description

      The TypeScript typings for the Node.js adapter are missing from the official NPM package.

      A possible workaround for now is to install the package directly from GitHub:

      yarn add https://github.com/keycloak/keycloak-nodejs-connect\#8.0.1
      

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  fatalmerlin Merlin Brandes
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: