Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-12516

Add a note to the docs that EAP adapter install script runs only on standalone mode

    Details

    • Docs QE Status:
      NEW
    • QE Status:
      NEW

      Description

      While trying to run adapter-install.cli using EAP in domain mode, the following error occurs:

      JBAS014883: No resource definition is registered for address [...]' not found
      

      That's because the script should be edited to add the profile to each operation. For example, using default profile:

      /profile=default/subsystem=security/security-domain=keycloak/:add
      /profile=default/subsystem=security/security-domain=keycloak/authentication=classic/:add(login-modules=[{ "code" => "org.keycloak.adapters.jboss.KeycloakLoginModule","flag" => "required"}])
      /extension=org.keycloak.keycloak-adapter-subsystem/:add(module=org.keycloak.keycloak-adapter-subsystem)
      /profile=default/subsystem=keycloak:add
      

      This should be noted on docs, in the sections:

      Another possible solution is adapt the script to accept the domain profile as parameter.

      Cheers!

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                zanini Ricardo Zanini Fernandes
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: