Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-10914

Cannot install artifact due to unresolved constraint in bundle in fuse test-apps

    Details

    • Sprint:
      Keycloak Sprint 25
    • Story Points:
      2
    • Docs QE Status:
      NEW
    • QE Status:
      NEW

      Description

      Fuse 6.3

      Could not start bundle mvn:org.keycloak.testsuite/fuse-example-cxf-jaxws/8.0.0-SNAPSHOT in feature(s) keycloak-fuse-6.3-example-8.0.0-SNAPSHOT: Unresolved constraint in bundle org.keycloak.testsuite.fuse-example-cxf-jaxws [355]: Unable to resolve 355.0: missing requirement [355.0] osgi.wiring.package; (&(osgi.wiring.package=javax.xml.bind)(version>=2.3.0)(!(version>=3.0.0)))\n
      

      Fuse 7

      Adding feature url mvn:org.keycloak/keycloak-osgi-features/8.0.0-SNAPSHOT-master-20190722-001425/xml/features\nAdding feature url mvn:org.keycloak.testsuite/fuse-example-keycloak-features/8.0.0-SNAPSHOT-master-20190722-001425/xml/features\n&#27;[31mError executing command: &#27;[0m&#27;[31;1mUnable to resolve root: missing requirement [root] osgi.identity; osgi.identity=keycloak-fuse-7.0-example; type=karaf.feature; version=\"[8.0.0.SNAPSHOT-master-20190722-001425,8.0.0.SNAPSHOT-master-20190722-001425]\"; filter:=\"(&(osgi.identity=keycloak-fuse-7.0-example)(type=karaf.feature)(version>=8.0.0.SNAPSHOT-master-20190722-001425)(version<=8.0.0.SNAPSHOT-master-20190722-001425))\" [caused by: Unable to resolve keycloak-fuse-7.0-example/8.0.0.SNAPSHOT-master-20190722-001425: missing requirement [keycloak-fuse-7.0-example/8.0.0.SNAPSHOT-master-20190722-001425] osgi.identity; osgi.identity=org.keycloak.testsuite.fuse-example-cxf-jaxrs-fuse7-undertow; type=osgi.bundle; version=\"[8.0.0.SNAPSHOT-master-20190722-001425,8.0.0.SNAPSHOT-master-20190722-001425]\"; resolution:=mandatory [caused by: Unable to resolve org.keycloak.testsuite.fuse-example-cxf-jaxrs-fuse7-undertow/8.0.0.SNAPSHOT-master-20190722-001425: missing requirement [org.keycloak.testsuite.fuse-example-cxf-jaxrs-fuse7-undertow/8.0.0.SNAPSHOT-master-20190722-001425] osgi.wiring.package; 
      filter:=\"(&(osgi.wiring.package=com.fasterxml.jackson.jaxrs.json)(version>=2.9.9))\"]]&#27;[0m\n
      

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                vramik Vlasta Ramik
                Reporter:
                vramik Vlasta Ramik
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: