Uploaded image for project: 'JBoss Web Services'
  1. JBoss Web Services
  2. JBWS-3666

Eclipse import of existing maven projects - remove errors "Plugin execution not covered by lifecycle configuration"

    XMLWordPrintable

Details

    Description

      add to the pom.xml maven profile which prevents errors "Plugin execution not covered by lifecycle configuration" during import of existing maven projects into eclipse with m2e

          <profile>
            <id>eclipse-m2e</id>
            <activation>
              <property>
                <name>!eclipse-m2e</name>
              </property>
            </activation>
            <build>
              <pluginManagement>
                <plugins>
                  <!--This plugin's configuration is used to store Eclipse m2e settings only. It has no influence on the Maven build itself. -->
                  <plugin>
                    <groupId>org.eclipse.m2e</groupId>
                    <artifactId>lifecycle-mapping</artifactId>
                    <version>1.0.0</version>
                    <configuration>
                      <lifecycleMappingMetadata>
                      <pluginExecutions>
                        <pluginExecution>
                          <pluginExecutionFilter>
                            <groupId>org.apache.maven.plugins</groupId>
                            <artifactId>maven-antrun-plugin</artifactId>
                            <versionRange>[1.7,)</versionRange>
                            <goals>
                              <goal>run</goal>
                            </goals>
                          </pluginExecutionFilter>
                          <action>
                            <ignore />
                          </action>
                        </pluginExecution>
                        <pluginExecution>
                          <pluginExecutionFilter>
                            <groupId>org.apache.maven.plugins</groupId>
                            <artifactId>maven-dependency-plugin</artifactId>
                            <versionRange>[2.4,)</versionRange>
                            <goals>
                              <goal>sources</goal>
                              <goal>copy</goal>
                            </goals>
                          </pluginExecutionFilter>
                          <action>
                            <ignore />
                          </action>
                        </pluginExecution>
                        <pluginExecution>
                          <pluginExecutionFilter>
                            <groupId>org.apache.maven.plugins</groupId>
                            <artifactId>maven-enforcer-plugin</artifactId>
                            <versionRange>[1.0.1,)</versionRange>
                            <goals>
                              <goal>enforce</goal>
                            </goals>
                          </pluginExecutionFilter>
                          <action>
                            <ignore />
                          </action>
                        </pluginExecution>
                      </pluginExecutions>
                      </lifecycleMappingMetadata>
                    </configuration>
                  </plugin>
                </plugins>
              </pluginManagement>
            </build>
          </profile>
      

      Attachments

        Activity

          People

            rhn-support-asoldano Alessio Soldano
            psakar@redhat.com Petr Sakar (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: