Uploaded image for project: 'JBoss Transaction Manager'
  1. JBoss Transaction Manager
  2. JBTM-3203

Align XTS SSL quickstart to use the WFLY18 bom when released

    XMLWordPrintable

    Details

      Description

      The XTS over SSL fails with dependency issue 'dependencies.dependency.version' for jakarta.enterprise:jakarta.enterprise.cdi-api:jar is missing. @ org.wildfly.quickstarts:wsat-simple:[unknown-version][1].
      The trouble is that the test runs with the most recent wildfly/quickstart repo and consumes the bom from WFLY17. There is not defined the jakarta dependencies yet. We need to wait for WFLY18 bom with jakarta dependencies is released and then the test setup has to be fixed.

      [1]

      [ERROR] 'dependencies.dependency.version' for jakarta.enterprise:jakarta.enterprise.cdi-api:jar is missing. @ org.wildfly.quickstarts:wsat-simple:[unknown-version], /home/jenkins/workspace/narayana-quickstarts/quickstart/wsat-simple/pom.xml, line 48, column 21
      
          at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:416)
          at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:672)
          at org.apache.maven.DefaultMaven.getProjectsForMavenReactor(DefaultMaven.java:663)
          at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:253)
          at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:155)
          at org.apache.maven.cli.MavenCli.execute(MavenCli.java:584)
          at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:216)
          at org.apache.maven.cli.MavenCli.main(MavenCli.java:160)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke(Method.java:498)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
          at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
          at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
      [ERROR]   
      [ERROR]   The project org.wildfly.quickstarts:wsat-simple:18.0.0.Final-SNAPSHOT (/home/jenkins/workspace/narayana-quickstarts/quickstart/wsat-simple/pom.xml) has 1 error
      [ERROR]     'dependencies.dependency.version' for jakarta.enterprise:jakarta.enterprise.cdi-api:jar is missing. @ org.wildfly.quickstarts:wsat-simple:[unknown-version], /home/jenkins/workspace/narayana-quickstarts/quickstart/wsat-simple/pom.xml, line 48, column 21
      

        Attachments

          Activity

            People

            Assignee:
            ochaloup@redhat.com Ondrej Chaloupka
            Reporter:
            ochaloup@redhat.com Ondrej Chaloupka
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: