Uploaded image for project: 'JBRULES'
  1. JBRULES
  2. JBRULES-3319

Update JDT compiler ECJ from 3.5.1 to 3.7.1 or higher

    Details

    • Type: Task
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Out of Date
    • Affects Version/s: 5.4.0.Beta1
    • Fix Version/s: FUTURE
    • Component/s: drools-compiler
    • Labels:
      None

      Description

      Currently not possible because:
      Only 3.7 and 3.7.1 are available on maven central at this time:
      http://search.maven.org/#search%7Cgav%7C1%7Cg%3A%22org.eclipse.jdt.core.compiler%22%20AND%20a%3A%22ecj%22
      And both of them have no OSGi information (while 3.5.1 does have it), so upgrading is not straightforward.

      I 've asked on eclipse.org about this issue:
      http://www.eclipse.org/forums/index.php/mv/msg/269046/769548/#msg_769548

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                ge0ffrey Geoffrey De Smet
                Reporter:
                ge0ffrey Geoffrey De Smet
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: