Uploaded image for project: 'JBRULES'
  1. JBRULES
  2. JBRULES-3226

Make the Drools hudson jobs compile using the Java 5 compiler.

    Details

    • Type: Task
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Out of Date
    • Affects Version/s: 5.3.0.Final
    • Fix Version/s: FUTURE
    • Component/s: None
    • Labels:
      None

      Description

      The Hudson/Jenkins jobs at https://hudson.jboss.org/jenkins/view/Drools%20jBPM/ currently use the java 6 compiler to build drools.

      However, Drools (and jBPM) are explicitly Java 5 compliant. Because the jobs use Java 6, code which is not compatible with Java 5 sometimes gets into the source tree.

      It would be helpful if all Drools jobs ran under the Java 5 JDK.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                ge0ffrey Geoffrey De Smet
                Reporter:
                marco.rietveld Marco Rietveld
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: