Uploaded image for project: 'Drools'
  1. Drools
  2. DROOLS-157

drools-compiler depends on antlr 2.7.7 and 3.3. Upgrade to antlr 3.4 to avoid having to depend on 2.x and 3.x at the same time

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Done
    • None
    • 6.0.0.CR2
    • None

    Description

      drools-compiler uses antlr 3.3 but has an additional dependency on old antlr:antlr 2.7.7 version.

      The v2 dependency is obsolete since antlr 3.1 (see http://www.antlr.org/jira/browse/ANTLR-180).

      Please remove the antlr:antlr dependency, for the next 5.2.x / 5.3.x release - thanks!

      Attachments

        Activity

          People

            etirelli Edson Tirelli
            marcelmay Marcel May (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: