Uploaded image for project: 'jBPM'
  1. jBPM
  2. JBPM-7057

Swagger UI does not load when not connected to the Internet

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Cannot Reproduce
    • 7.6.0.Final
    • None
    • KieServer
    • Hide

      1) Disconnect machine from the network/
      2) Start Decision Manager 7 or any version of KIE-Server that includes the Swagger UI and extension.
      3) Try to load KIE-Server docs at "http://

      {host}

      :

      {port}

      /kie-server/docs"

      Show
      1) Disconnect machine from the network/ 2) Start Decision Manager 7 or any version of KIE-Server that includes the Swagger UI and extension. 3) Try to load KIE-Server docs at "http:// {host} : {port} /kie-server/docs"
    • NEW
    • NEW

    Description

      The new Swagger UI on KIE-Server does not load properly when not connected to the Internet. This is particularly problematic to installations at enterprises where KIE-Server/Decision Server platforms usually don't have direct access to the outside world.

      The problem is due to the Google CSS that's loaded in the index.html. We need to include that css in our distribution.

      Attachments

        Activity

          People

            rhn-gps-ddoyle Duncan Doyle
            rhn-gps-ddoyle Duncan Doyle
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: