Uploaded image for project: 'JBoss Enterprise Application Platform 6'
  1. JBoss Enterprise Application Platform 6
  2. JBPAPP6-1561

Invalid POM for org.hornetq:messaging:pom:2.2.21.Final-redhat-1

    Details

      Description

      The dependency on javacc might be only a plugin dependency, I'm not sure it's even needed in the main <dependencies> section. However, the version specified in the plugin declaration does not match the version of javacc in the Mead repository (4.0 vs. 5.0-redhat-1).

      [WARNING] The POM for org.hornetq:messaging:pom:2.2.21.Final-redhat-1 is invalid, transitive dependencies (if any) will not be available: 3 problems were encountered while building the effective model for org.hornetq:messaging:2.2.21.Final-redhat-1
      [ERROR] 'dependencies.dependency.version' for net.java.dev.javacc:javacc:jar is missing. @
      [ERROR] 'dependencies.dependency.version' for org.jboss.naming:jnpserver:jar is missing. @
      [ERROR] 'dependencies.dependency.version' for org.jboss.apiviz:apiviz:jar is missing. @
      

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                fnasser Fernando Nasser
                Reporter:
                pgier Paul Gier
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: