Uploaded image for project: 'JBoss Enterprise Application Platform 6'
  1. JBoss Enterprise Application Platform 6
  2. JBPAPP6-1096

jbosgi-spi-3.1.0.Final-redhat-1.pom has a dependency on args4j which is not part of the Repository.

    Details

      Description

      'args4j' is not part of EAP 6 Repository but OSGI components have a dependency on the component.

      Confirm that we ship the two following components, can grep for the following JARs:
      jbosgi-framework-core-1.3.0.Final-redhat-1.jar
      jbosgi-spi-3.1.0.Final-redhat-1.jar

      jbosgi-spi-3.1.0.Final-redhat-1.pom has a dependency on 'args4j' which is not part of the Repository.

      To recreate:
      Delete your current local maven repo.
      Follow instructions to setup the maven repo that is available as a download through the customer portal.
      In JBDev Studio go to JBoss Central and select new Java EE Web Project. Add following dependencies:
      <dependency>
      <groupId>org.osgi</groupId>
      <artifactId>org.osgi.core</artifactId>
      <version>4.2.0</version>
      <scope>provided</scope>
      </dependency>
      <dependency>
      <groupId>org.jboss.osgi.framework</groupId>
      <artifactId>jbosgi-framework-core</artifactId>
      <version>1.3.0.Final-redhat-1</version>
      <scope>provided</scope>
      </dependency>
      Save and the error should show up.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                pgier Paul Gier
                Reporter:
                edrich Eric Rich
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: