Uploaded image for project: 'JBoss OSGi'
  1. JBoss OSGi
  2. JBOSGI-624

Bundle importing the package of multiple versions isn't supported

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Rejected
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      I have a OSGI service bundle with Bundle-Version as "1.0.0" in which i have exported this particular package "com.example.test" and I have a OSGI web client where i am importing this package with version as "[1.0.0,2.0.0]" (i.e)
      Import-Package:com.example.test;version:[1.0.0,3.0.0]. Now when i start the client bundle after the service bundle I am getting this exception:

      13:21:36,952 WARN [org.jboss.as.osgi] (MSC service thread 1-10) JBAS011910: Can
      not resolve requirements: [XPackageRequirement[atts=

      {osgi.wiring.package=com.example.test, version=[1.0.0,2.0.0]}

      ,[TestServlet:0.0.0]]]

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                thomas.diesler Thomas Diesler
                Reporter:
                hariohmprasath Hari Ohm Prasath
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: