Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-13546

Fix matrix param url generated from jaxrs explorer

    XMLWordPrintable

Details

    • Hide

      EXEC: create a jaxrs service:

      @Path("/")
      public class Service {
      
      	@GET
      	@Path("/{id}")
      	public String method(@PathParam("id") int id,
      			             @MatrixParam("m1") String m1,
      			             @QueryParam("q1") String q1) {
      		return id + " " + m1 + " " + q1;
      	}
      	
      }
      

      EXEC: invoke service via JAX RS explorer (Run As -> Run on Server)
      ASSERT: type of jaxrs parameters are set correctly in url text field of Web Service tester view
      FAIL: matrix parameter is not set correctly in url. It should be "m1={m1:TYPE}" not "m1={TYPE}". Query parameters generating is correct.

      The problem here is, that if I type:

      http://localhost:8080/prj/rest/{id};m1={java.lang.MYPARAM}?q1={q1:java.lang.MYPARAM}
      

      into url text field and invoke web service, dialog for setting values for jax rs parameters is not valid.

      Show
      EXEC: create a jaxrs service: @Path( "/" ) public class Service { @GET @Path( "/{id}" ) public String method(@PathParam( "id" ) int id, @MatrixParam( "m1" ) String m1, @QueryParam( "q1" ) String q1) { return id + " " + m1 + " " + q1; } } EXEC: invoke service via JAX RS explorer (Run As -> Run on Server) ASSERT: type of jaxrs parameters are set correctly in url text field of Web Service tester view FAIL: matrix parameter is not set correctly in url. It should be "m1={m1:TYPE}" not "m1={TYPE}". Query parameters generating is correct. The problem here is, that if I type: http: //localhost:8080/prj/ rest /{id};m1={java.lang.MYPARAM}?q1={q1:java.lang.MYPARAM} into url text field and invoke web service, dialog for setting values for jax rs parameters is not valid.
    • ?

    Description

      There is difference when generating url from JAX RS explorer with parameters (matrix, query). This can cause issue when entering values in "WS Tester: URL Parameters" dialog.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              jjankovi Jaroslav Jankovič (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated: