Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-12648

Error in error log when running JSF bot tests

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.0.0.Alpha2
    • Fix Version/s: 4.0.0.Alpha2
    • Component/s: jsf
    • Labels:
      None

      Description

      When running JSF Swt Bot tests on Jenkins there is this error in ErrorLog making test to fail:

      !ENTRY org.eclipse.osgi 4 0 2012-09-20 02:18:09.081
      !MESSAGE Application error
      !STACK 1
      java.lang.ClassCastException: [Ljava.lang.String; cannot be cast to java.lang.String
      	at org.jboss.tools.common.model.ui.dnd.ModelTransfer.javaToNative(ModelTransfer.java:38)
      	at org.eclipse.swt.dnd.ClipboardProxy.getFunc(ClipboardProxy.java:138)
      	at org.eclipse.swt.internal.gtk.OS._gtk_main_do_event(Native Method)
      	at org.eclipse.swt.internal.gtk.OS.gtk_main_do_event(OS.java:8307)
      	at org.eclipse.swt.widgets.Display.eventProc(Display.java:1192)
      	at org.eclipse.swt.internal.gtk.OS._gtk_clipboard_store(Native Method)
      	at org.eclipse.swt.internal.gtk.OS.gtk_clipboard_store(OS.java:6338)
      	at org.eclipse.swt.dnd.ClipboardProxy.dispose(ClipboardProxy.java:93)
      	at org.eclipse.swt.dnd.ClipboardProxy$1.handleEvent(ClipboardProxy.java:52)
      	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
      	at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4192)
      	at org.eclipse.swt.widgets.Display.release(Display.java:3225)
      	at org.eclipse.swt.graphics.Device.dispose(Device.java:248)
      	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:140)
      	at org.eclipse.tycho.surefire.osgibooter.UITestApplication.runApplication(UITestApplication.java:31)
      	at org.eclipse.tycho.surefire.osgibooter.AbstractUITestApplication.run(AbstractUITestApplication.java:114)
      	at org.eclipse.tycho.surefire.osgibooter.UITestApplication.start(UITestApplication.java:37)
      	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
      	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
      	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
      	at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
      	at org.eclipse.equinox.launcher.Main.main(Main.java:1414)
      

      This error is not present on jobs running on OSX and MS Windows either when running locally via maven.

        Attachments

          Activity

            People

            Assignee:
            scabanovich Viacheslav Kabanovich (Inactive)
            Reporter:
            vpakan Vlado Pakan (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: