Uploaded image for project: 'JBoss Enterprise Web Server'
  1. JBoss Enterprise Web Server
  2. JBEWS-255

routing table lookup creates performance issues.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: EWS 1.0.2
    • Fix Version/s: EWS 2.0.0
    • Labels:
      None
    • Environment:

      EWS 1.0.2
      Worker module
      HTTPS instead of AJP connector.

      Description

      Load tests fail on larger load (e.g. 150 concurrent users or more) in load-balanced, clustered Enterprise Portal Environment
      With fewer concurrent requests (~50) this issue does not manifest through mod_cluster. This issue happens only with mod_cluster and larger load.

      There are no problems with even larger loads (~200) when the same tests are executed directly on the nodes (without mod_cluster). We're using EWS 1.0.2 and thus the version of Apache that's bundled with it. We're using worker module. We're also using HTTPS instead of AJP connector. as usage of SSL is a requirement.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              permaine Permaine Cheung
              Reporter:
              lakagwu Lami Akagwu
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: