Uploaded image for project: 'JBoss ESB'
  1. JBoss ESB
  2. JBESB-3756

Hibernate/juddi error upon deployment in JBoss AS 6.1.0.Final

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Optional
    • Resolution: Done
    • Affects Version/s: 4.10
    • Fix Version/s: 4.11
    • Component/s: Deployment
    • Labels:
      None

      Description

      Upon start up of JBoss ESB 4.10 on JBoss AS 6.1.0.Final the following error is logged in the console:

      08:57:58,495 INFO [Configuration] Reading mappings from resource : META-INF/esb-juddi-orm.xml
      08:57:58,513 ERROR [ErrorLogger] Error parsing XML (5) : cvc-complex-type.3.1: Value '1.0' of attribute 'version' of element 'entity-mappings' is not
      valid with respect to the corresponding attribute use. Attribute 'version' has a fixed value of '2.0'.
      

      The mapping error is really just a warning that hibernate could not parse the mapping file with JPA 2.0, but hibernate will fallback to 1.0 and things will work as expected. Details can be found here

      A possible solution for this is to have a different esb-juddi-orm.xml for as6 which will be used when installing to AS 6.1.0.Final.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                beve Daniel Bevenius
                Reporter:
                beve Daniel Bevenius
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: