Details

      Description

      I can query the JMX attributes for a topic when the HornetQ server is not clustered:

      ./twiddle.sh -s 10.0.0.150:1099 -u admin -p admin get org.hornetq:module=JMS,type=Topic,name=\"TestTopic\"
      JNDIBindings=[Ljava.lang.String;@1d6a56e
      DurableMessageCount=0
      NonDurableMessageCount=0
      SubscriptionCount=2
      DurableSubscriptionCount=0
      NonDurableSubscriptionCount=2
      Address=jms.topic.TestTopic
      Name=TestTopic
      Temporary=false
      MessageCount=0
      DeliveringCount=0
      MessagesAdded=4

      However, when I start a second node (active-active), reconnect all clients and post messages to the topic, all attributes return zero:

      ./twiddle.sh -s 10.0.0.150:1099 -u admin -p admin get org.hornetq:module=JMS,type=Topic,name=\"TestTopic\"
      JNDIBindings=[Ljava.lang.String;@676437
      DurableMessageCount=0
      NonDurableMessageCount=0
      SubscriptionCount=0
      DurableSubscriptionCount=0
      NonDurableSubscriptionCount=0
      Address=jms.topic.TestTopic
      Name=TestTopic
      Temporary=false
      MessageCount=0
      DeliveringCount=0
      MessagesAdded=0

      This happens for both nodes in the cluster.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  jbertram Justin Bertram
                  Reporter:
                  dgrove_redhat.com Doug Grove
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: