Uploaded image for project: 'HAL'
  1. HAL
  2. HAL-1651

For slave node jvm instance which is running on another VM, start/stop and other option are not showing in EAP 7.2.4 in management console when rbac is enabled.

    XMLWordPrintable

Details

    • This issue is security relevant
    • Hide

      Steps to reproduce.

      Run EAP 7.2.4 in master-slave architecture.
      Add one management user.
      Run master node in one VM
      Run slave node in another VM

      Enable rbac and include that user.

      Now access the management console.
      Go to Admin Console --> Runtime --> Hosts --> Host Name (Slave) --> JVM (server) --> Click on Drop down option associated with View button.

      You can see only "Edit URL" option is showing. Others option like kill, destroy. start, stop are not available.

      Same issue is not observed without rbac and if master-slave host are running on same VM.

      Attaching screenshot for more reference.

      Show
      Steps to reproduce. Run EAP 7.2.4 in master-slave architecture. Add one management user. Run master node in one VM Run slave node in another VM Enable rbac and include that user. Now access the management console. Go to Admin Console --> Runtime --> Hosts --> Host Name (Slave) --> JVM (server) --> Click on Drop down option associated with View button. You can see only "Edit URL" option is showing. Others option like kill, destroy. start, stop are not available. Same issue is not observed without rbac and if master-slave host are running on same VM. Attaching screenshot for more reference.

    Description

      Hi,

      When using master-slave architecture in EAP 7.2.4 with rbac enabled , there is no option like start/stop is showing for jvm instance which is running on slave node(on the other VM).

      Interestingly if you add one jvm in master host, management console show such option like start/stop but for slave node jvm instance which is running on another VM there is no such option shown from the management console.

      Same issue is not observed in EAP 7.2.3 when rbac is enabled.
      Even in EAP 7.2.4, no such issue is observed if rbac is disabled.

      Attachments

        Issue Links

          Activity

            People

              thofman Tomas Hofman
              thofman Tomas Hofman
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: