Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 3.0.0-CR01
    • Component/s: None
    • Labels:
      None

      Description

      On an internal server, sometimes I get the HTML of the login page displayed in text format instead of the rendered HTML.

      It seems to be due to a wrong content type sent. In Firefox I get :
      Date Thu, 04 Feb 2010 03:03:31 GMT
      Server Apache/2.2.9 (Fedora)
      Set-Cookie JSESSIONIDSSO=CD538AAD44F3B33DD9E213B6CC9ABD07; Expires=Thu, 01-Jan-1970 00:00:10 GMT
      Pragma No-cache
      Cache-Control no-cache
      Expires Thu, 01 Jan 1970 00:00:00 UTC
      Vary Accept-Encoding
      Content-Encoding gzip
      Connection close
      Transfer-Encoding chunked
      Content-Type text/plain; charset=UTF-8

      using the w3c validator I'm also getting a content type text/plain

      But using CURL, i'm getting the good header :
      $ curl -I http://xxx.exoplatform.org/portal/private/classic/Dashboard
      HTTP/1.1 200 OK
      Date: Thu, 04 Feb 2010 03:03:54 GMT
      Server: Apache/2.2.9 (Fedora)
      Set-Cookie: JSESSIONID=EBEAAA2E6A42B34D1F99F58F0E421D62; Path=/portal
      Cache-Control: no-cache
      Content-Length: 42912
      Vary: Accept-Encoding
      Connection: close
      Content-Type: text/html;charset=UTF-8

      $

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  liem_nguyen LiemNC
                  Reporter:
                  jeremi23 jerem j
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: