Details

      Description

      When i configure SPNEGO SSO for Gatein,
      It work ok when i login with "login" link at top navigation bar. But when i try to access to page that rerquire login, (for example http://server.local.network:8080/portal/g/:platform:administrators/administration/registry), it will redirect to /login and i will not be logged in automatically with SPNEGO because spnego only work when it redirect to /dologin

      I think when SSO is enabled, we should redirect to /sso instead of /login when user try to access page that require login, then SSO will redirect to loginURL which was configured.
      It's similar that we change link of "login" at top navigation bar to /sso when SSO is enabled.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                trong.tran Trong Tran
                Reporter:
                nttuyen266 Tuyen Nguyen The
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 4 hours
                  4h
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 4 hours
                  4h