Uploaded image for project: 'Fuse Tooling'
  1. Fuse Tooling
  2. FUSETOOLS-2798

Fix FuseIntegrationProjectCreatorRunnableXXXIT failing test with JDK9 with error "Build path specifies execution environment JavaSE-1.8. There are no JREs installed in the workspace that are strictly compatible with this environment."

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 10.2.0
    • Fix Version/s: 11.2.0
    • Component/s: None
    • Labels:
      None

      Description

      Expecting empty but was:<[

      {"severity"=1, "location"="Build path", "resource affected"="/home/jenkins/workspace/jbosstools-fuse_master_jdepsTest/sources/editor/tests/org.fusesource.ide.projecttemplates.tests.integration/target/work sp@cé/FuseIntegrationProjectCreatorRunnableCheckCatalogCacheLoadingIT-SimpleBlueprintProject-2.17.0.redhat-630187", "message"="Build path specifies execution environment JavaSE-1.8. There are no JREs installed in the workspace that are strictly compatible with this environment. ", "type: "="org.eclipse.jdt.launching.jreContainerMarker", "Creation time: "=1517511621230L}

      ]>

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                aurelien.pupier Aurélien Pupier
                Reporter:
                aurelien.pupier Aurélien Pupier
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: