Uploaded image for project: 'FeedHenry'
  1. FeedHenry
  2. FH-2853

Switch the fhc 'latest' tag to point to the 2.x stream

    XMLWordPrintable

    Details

    • Sprint:
      IR293 - DevExp 101
    • Story Points:
      2
    • Release Notes Text:
      Hide
      === {ProductShortName} Command Line Tool (FHC) Version 2

      With this release of {ProductShortName} the default version of the {ProductShortName} command line tool (FHC) changes to Version 2. For an introduction to fhc, see link:{GettingStarted}#getting-started-fhc[Getting Started With FHC]. For more information about FHC Version 2, see the link:https://github.com/feedhenry/fh-fhc/[FHC repository].
      Show
      === {ProductShortName} Command Line Tool (FHC) Version 2 With this release of {ProductShortName} the default version of the {ProductShortName} command line tool (FHC) changes to Version 2. For an introduction to fhc, see link:{GettingStarted}#getting-started-fhc[Getting Started With FHC]. For more information about FHC Version 2, see the link: https://github.com/feedhenry/fh-fhc/ [FHC repository].
    • Release Notes Docs Status:
      Documented as Feature Request
    • Deployment Notes:
      Hide
      This change would require fh-fhc to be published in different way.
      We changed label to use latest. To publish this package to npm just use:

      npm publish fh-fhc.tar.gz

      Version: http://bob.feedhenry.net:8080/job/fh-fhc_pullrequests/500/
      Show
      This change would require fh-fhc to be published in different way. We changed label to use latest. To publish this package to npm just use: npm publish fh-fhc.tar.gz Version: http://bob.feedhenry.net:8080/job/fh-fhc_pullrequests/500/

      Description

      What
      Change the 'latest' tag in npmjs for fhc to point to the latest 2.x version.
      The current tag is:

       { latest: '1.1.5',
           'latest-1': '1.2.0',
           'latest-2': '2.15.5-457' },
      

      Why
      Feedback from users & product:
      Evan Shortiss & Alistair Graham

      +1 on this! It's especially a good idea to simplify onborading new customers and consultants. It's confusing that all new domains are v3 and if you don't install fh-fhc@latest-2 many commands are missing/broken.

      I'l like latest to be 2.x please!

      Considerations

      from Ciaran Byrne

      We should note in the blogpost/release that this will affect any new users in Legacy grids (LON3/CSG1) and provide them with the info to install 1.1.5 if they need it - there are still active customers there, but to be fair I don't know how many new users there would be

        Attachments

          Activity

            People

            Assignee:
            wtrocki Wojciech Trocki
            Reporter:
            davidmartin David Martin
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: