Uploaded image for project: 'AMQ Broker'
  1. AMQ Broker
  2. ENTMQBR-4618

[LTS] LVQ non destructive: unable to consume message

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Done
    • AMQ 7.8.0.GA
    • None
    • None
    • None
    • Hide

      Replace, [BROKER INSTALLATION]/examples/features/standard/last-value-queue/src/main/java/org/apache/activemq/artemis/jms/example/LastValueQueueExample.java with [^LastValueQueueExample.java]

      Create a broker with the following address:

       

            <address name="testlvq-nondestructive">
              <anycast>
                <queue name="testlvq-nondestructive" last-value="true" non-destructive="true">
                  <durable>true</durable>
                </queue>
              </anycast>
            </address>

       

      1. Start the broker
      2. Run the sample project last-value-queue with
        mvn -PnoServer -DNO_PROD -DQUEUE_NAME=testlvq-nondestructive verify
      3. Run in another terminal, the same sample project with
        mvn -PnoServer -DNO_CONS -DQUEUE_NAME=testlvq-nondestructive verify

      The second produces the message but the first will never receive it.

      Stop the broker and retry all 3 steps before again and all will work fine.

      If the queue is purged the issue occurs again.

       

       

       

       

       

      Show
      Replace, [BROKER INSTALLATION] /examples/features/standard/last-value-queue/src/main/java/org/apache/activemq/artemis/jms/example/LastValueQueueExample.java with [^LastValueQueueExample.java] Create a broker with the following address:   <address name= "testlvq-nondestructive" > <anycast> <queue name= "testlvq-nondestructive" last-value= " true " non-destructive= " true " > <durable> true </durable> </queue> </anycast> </address>   Start the broker Run the sample project last-value-queue with mvn -PnoServer -DNO_PROD -DQUEUE_NAME=testlvq-nondestructive verify Run in another terminal, the same sample project with mvn -PnoServer -DNO_CONS -DQUEUE_NAME=testlvq-nondestructive verify The second produces the message but the first will never receive it. Stop the broker and retry all 3 steps before again and all will work fine. If the queue is purged the issue occurs again.          

    Description

      It seems that if a consumer is connected to an empty LVQ nondestructive it's no more able to consume next messages produced.

      Attachments

        Issue Links

          Activity

            People

              rhn-support-jbertram Justin Bertram
              rhn-support-jsherman Jason Sherman
              Roman Vais Roman Vais
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: