Uploaded image for project: 'AMQ Broker'
  1. AMQ Broker
  2. ENTMQBR-4606

[LTS-7.8] 'data exp' command doesn't exports all message properties

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Done
    • AMQ 7.8.0.GA
    • None
    • None

    Description

      "data exp" ignore most of the message properties and attributes that instead are available with "./artemis consumer --data".

      "./artemis data exp" output

            <message id="2863" priority="4" expiration="0" timestamp="0" type="text">
               <properties>
                  <property name="_AMQ_ROUTING_TYPE" value="1" type="byte"/>
                  <property name="JMS_AMQP_ORIGINAL_ENCODING" value="5" type="short"/>
                  <property name="_AMQ_ORIG_QUEUE" value="test" type="simple-string"/>
                  <property name="_AMQ_ORIG_ADDRESS" value="test::test" type="simple-string"/>
                  <property name="_AMQ_ORIG_MESSAGE_ID" value="2849" type="long"/>
               </properties>
               <queues>
                  <queue name="DLQ"/>
               </queues>
               <body>
                  <...> 
               </body>
            </message>
      
      • "./artemis consumer --data"
       
      <message id="2863" priority="4" expiration="0" timestamp="1611845865326" type="text" user-id="88ebdd34-617c-11eb-92b2-a4c3f095b4ec">
        <properties>
          <property name="JMS_AMQP_MA_x-opt-ORIG-MESSAGE-ID" value="2849" type="long"/>
          <property name="JMS_AMQP_MA_x-opt-ORIG-QUEUE" value="test" type="simple-string"/>
          <property name="JMS_AMQP_MA_x-opt-jms-dest" value="0" type="byte"/>
          <property name="_AMQ_ROUTING_TYPE" value="1" type="byte"/>
          <property name="JMS_AMQP_ORIGINAL_ENCODING" value="5" type="short"/>
          <property name="JMS_AMQP_MA_x-opt-ORIG-ADDRESS" value="test::test" type="simple-string"/>
          <property name="testHeaderProperty" value="test header property value" type="simple-string"/>
          <property name="JMS_AMQP_HEADERDURABLE" value="true" type="boolean"/>
          <property name="_AMQ_ORIG_MESSAGE_ID" value="2849" type="long"/>
          <property name="JMS_AMQP_MA_x-opt-jms-msg-type" value="5" type="byte"/>
          <property name="NATIVE_MESSAGE_ID" value="ID:4b8a9e3b-5d78-434a-972c-4502c31a34c7:1:2:1-1" type="simple-string"/>
          <property name="breadcrumbId" value="ID-agagliar-remote-csb-1611845862983-0-1" type="simple-string"/>
          <property name="_AMQ_ORIG_QUEUE" value="test" type="simple-string"/>
          <property name="JMS_AMQP_HEADER" value="true" type="boolean"/>
          <property name="firedTime" value="Thu Jan 28 15:57:45 CET 2021" type="simple-string"/>
          <property name="_AMQ_ORIG_ADDRESS" value="test::test" type="simple-string"/>
        </properties>
        <body><...></body>
      </message>
      

      Body of message in above outputs has been replaced with "<...>" because it bugs jira.

      Attachments

        Issue Links

          Activity

            People

              dbruscin Domenico Francesco Bruscino
              dbruscin Domenico Francesco Bruscino
              Roman Vais Roman Vais
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: