Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-11124

SB2 BOM contains unproductized version of kafka clients

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: fuse-7.4-GA
    • Component/s: None
    • Labels:
      None

      Description

      Spring Boot 2 bom doesn't contain correct version of org.apache.kafka:kafka-clients:2.0.1 Look here: [2]. It should be 2.1.1.redhat-00002 according to [1], where is the diff of boms in eap, sb1 and karaf.

      Also the org.apache.kafka:kafka_2.11:2.0.1 is different than what is other boms (2.1.1). Please align versions between runtimes if possible.

      [1] http://files.fuse-qe.eng.rdu2.redhat.com/fuse-boms/fuse-bom-7.4.0.fuse-740036-redhat-00001/fuse-bom-check-all-7.4.0.fuse-740036-redhat-00001.txt

      [2] http://files.fuse-qe.eng.rdu2.redhat.com/fuse-boms/fuse-bom-7.4.0.fuse-sb2-740019-redhat-00001/fuse-bom-check-sb-7.4.0.fuse-sb2-740019-redhat-00001.txt

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                valdar Andrea Tarocchi
                Reporter:
                vkasala Viliam Kasala
                Tester:
                Tomas Turek
              • Votes:
                0 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: