Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-10320

Fix fuse-7.3-release-pipeline Wildfly Camel :: Feature :: Pack MODULE DEPENDENCY ERRORS DETECTED!!

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Duplicate Issue
    • Affects Version/s: fuse-7.3
    • Fix Version/s: None
    • Component/s: Build, WildFly Camel
    • Labels:
      None

      Description

      [INFO] ------------------------------------------------------------------------
      [INFO] Building Wildfly Camel :: Feature :: Pack 5.3.0.fuse-730027
      [INFO] ------------------------------------------------------------------------
      [INFO] 
      [INFO] --- maven-enforcer-plugin:1.3.1:enforce (enforce-versions) @ wildfly-camel-feature-pack ---
      [INFO] 
      [INFO] --- properties-maven-plugin:1.0.0:set-system-properties (default) @ wildfly-camel-feature-pack ---
      [INFO] Set 1 system property
      [INFO] 
      [INFO] --- maven-dependency-plugin:2.10:unpack (unpack-wildfly-feature-pack) @ wildfly-camel-feature-pack ---
      [INFO] Configured Artifact: org.jboss.eap:wildfly-feature-pack:7.2.0.GA-redhat-00005:zip
      [INFO] Unpacking /home/jenkins/.m2/repository/org/jboss/eap/wildfly-feature-pack/7.2.0.GA-redhat-00005/wildfly-feature-pack-7.2.0.GA-redhat-00005.zip to /home/jenkins/wildfly-camel/feature/pack/target/wildfly-feature-pack with includes "configuration/standalone/**" and excludes ""
      [INFO] 
      [INFO] --- wildfly-feature-pack-build-maven-plugin:1.2.10.Final:build (feature-pack-build) @ wildfly-camel-feature-pack ---
      [INFO] 
      [INFO] --- wildfly-server-provisioning-maven-plugin:1.2.10.Final:build (provision-wildfly) @ wildfly-camel-feature-pack ---
      [INFO] 
      [INFO] --- wildfly-server-provisioning-maven-plugin:1.2.10.Final:build (provision-wildfly-camel) @ wildfly-camel-feature-pack ---
      [INFO] 
      [INFO] --- groovy-maven-plugin:2.0:execute (module-check) @ wildfly-camel-feature-pack ---
      
      MODULE DEPENDENCY ERRORS DETECTED!!
      
      net.sourceforge.cssparser:main   unused in distro but defined in modules/etc/smartics/other-modules.xml
      net.sourceforge.htmlunit:main   unused in distro but defined in modules/etc/smartics/other-modules.xml
      org.eclipse.jetty.websocket:main   unused in distro but defined in modules/etc/smartics/other-modules.xml
      org.w3c.css.sac:main   unused in distro but defined in modules/etc/smartics/other-modules.xml
      
      [INFO] ------------------------------------------------------------------------
      [INFO] Reactor Summary:
      [INFO] 
      [INFO] Wildfly Camel ...................................... SUCCESS [  3.105 s]
      [INFO] Wildfly Camel :: BOM ............................... SUCCESS [  0.415 s]
      [INFO] Wildfly Camel :: Common ............................ SUCCESS [  1.603 s]
      [INFO] Wildfly Camel :: Config ............................ SUCCESS [  3.522 s]
      [INFO] Wildfly Camel :: Subsystem ......................... SUCCESS [  0.410 s]
      [INFO] Wildfly Camel :: Subsystem :: Core ................. SUCCESS [  2.086 s]
      [INFO] WildFly Camel :: CXF Undertow ...................... SUCCESS [  0.722 s]
      [INFO] Wildfly Camel :: Subsystem :: CDI .................. SUCCESS [  0.540 s]
      [INFO] Wildfly Camel :: Subsystem :: Security ............. SUCCESS [  0.614 s]
      [INFO] Wildfly Camel :: Subsystem :: Undertow ............. SUCCESS [  0.724 s]
      [INFO] Wildfly Camel :: Feature ........................... SUCCESS [  0.581 s]
      [INFO] Wildfly Camel :: Feature :: Common ................. SUCCESS [  0.427 s]
      [INFO] Wildfly Camel :: Feature :: Modules ................ SUCCESS [ 17.730 s]
      [INFO] Wildfly Camel :: Feature :: ExtrasA ................ SUCCESS [  1.197 s]
      [INFO] Wildfly Camel :: Feature :: ExtrasB ................ SUCCESS [  0.820 s]
      [INFO] Wildfly Camel :: Feature :: ExtrasC ................ SUCCESS [  0.799 s]
      [INFO] Wildfly Camel :: Feature :: Pack ................... FAILURE [  7.952 s]
      [INFO] Wildfly Camel :: Catalog ........................... SKIPPED
      [INFO] Wildfly Camel :: Enricher .......................... SKIPPED
      [INFO] Wildfly Camel :: Testsuite ......................... SKIPPED
      [INFO] Wildfly Camel :: Testsuite :: Common ............... SKIPPED
      [INFO] Wildfly Camel :: Testsuite :: Camel ................ SKIPPED
      [INFO] Wildfly Camel :: Testsuite :: Standalone ........... SKIPPED
      [INFO] Wildfly Camel :: Testsuite :: Standalone :: Smoke .. SKIPPED
      [INFO] Wildfly Camel :: Testsuite :: Standalone :: Basic .. SKIPPED
      [INFO] Wildfly Camel :: Testsuite :: Standalone :: Extra .. SKIPPED
      [INFO] Wildfly Camel :: Testsuite :: Standalone :: Docker . SKIPPED
      [INFO] Wildfly Camel :: Archetypes ........................ SKIPPED
      [INFO] Wildfly Camel :: Archetypes :: CDI ................. SKIPPED
      [INFO] Wildfly Camel :: Archetypes :: Spring .............. SKIPPED
      [INFO] Wildfly Camel :: Patch ............................. SKIPPED
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 45.421 s
      [INFO] Finished at: 2019-03-10T09:07:19+00:00
      [INFO] Final Memory: 372M/1350M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal org.codehaus.gmaven:groovy-maven-plugin:2.0:execute (module-check) on project wildfly-camel-feature-pack: Execution module-check of goal org.codehaus.gmaven:groovy-maven-plugin:2.0:execute failed: org.apache.maven.plugin.MojoExecutionException: Module dependency conflicts were detected. Please fix your module dependencies. -> [Help 1]
      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.codehaus.gmaven:groovy-maven-plugin:2.0:execute (module-check) on project wildfly-camel-feature-pack: Execution module-check of goal org.codehaus.gmaven:groovy-maven-plugin:2.0:execute failed: org.apache.maven.plugin.MojoExecutionException: Module dependency conflicts were detected. Please fix your module dependencies.
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
      	at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
      	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
      	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
      	at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:498)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
      Caused by: org.apache.maven.plugin.PluginExecutionException: Execution module-check of goal org.codehaus.gmaven:groovy-maven-plugin:2.0:execute failed: org.apache.maven.plugin.MojoExecutionException: Module dependency conflicts were detected. Please fix your module dependencies.
      	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:145)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207)
      	... 20 more
      Caused by: java.lang.RuntimeException: org.apache.maven.plugin.MojoExecutionException: Module dependency conflicts were detected. Please fix your module dependencies.
      	at com.google.common.base.Throwables.propagate(Throwables.java:160)
      	at org.codehaus.gmaven.adapter.impl.GroovyRuntimeImpl$3.call(GroovyRuntimeImpl.java:145)
      	at groovy.lang.Closure.call(Closure.java:427)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:498)
      	at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:90)
      	at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:233)
      	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:1085)
      	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:909)
      	at groovy.lang.MetaClassImpl.invokePropertyOrMissing(MetaClassImpl.java:1131)
      	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:1087)
      	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:909)
      	at org.codehaus.groovy.runtime.callsite.PogoMetaClassSite.callCurrent(PogoMetaClassSite.java:66)
      	at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCallCurrent(CallSiteArray.java:49)
      	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:133)
      	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:141)
      	at module-checker.run(module-checker.groovy:367)
      	at groovy.lang.GroovyShell.evaluate(GroovyShell.java:518)
      	at org.codehaus.gmaven.adapter.impl.ScriptExecutorImpl.execute(ScriptExecutorImpl.java:80)
      	at org.codehaus.gmaven.plugin.ExecuteMojo$1.run(ExecuteMojo.java:100)
      	at org.codehaus.gmaven.plugin.util.SystemNoExitGuard.run(SystemNoExitGuard.java:45)
      	at org.codehaus.gmaven.plugin.ExecuteMojo.run(ExecuteMojo.java:96)
      	at org.codehaus.gmaven.plugin.MojoSupport.execute(MojoSupport.java:45)
      	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
      	... 21 more
      Caused by: org.apache.maven.plugin.MojoExecutionException: Module dependency conflicts were detected. Please fix your module dependencies.
      	at org.codehaus.gmaven.plugin.FailClosureTarget.call(FailClosureTarget.java:83)
      	at org.codehaus.gmaven.adapter.impl.GroovyRuntimeImpl$3.call(GroovyRuntimeImpl.java:142)
      	... 45 more
      

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  thomas.diesler Thomas Diesler
                  Reporter:
                  aurelien.pupier Aurélien Pupier
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: