Uploaded image for project: 'Red Hat Container Development Kit'
  1. Red Hat Container Development Kit
  2. CDK-397

OCP preflight check uses docker v1 API which is no longer available

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 3.8.0
    • Component/s: minishift
    • Labels:
      None

      Description

      Preflight check for OpenShift version fails with the following error:

      ```
      [localhost minishift]$ minishift start
      – Starting profile 'minishift'
      – Check if deprecated options are used ... OK
      – Checking if https://mirror.openshift.com is reachable ... OK
      – Checking if requested OpenShift version 'v3.11.69' is valid ... FAIL
      ```

      Due to https://access.redhat.com/announcements/3962751 this url on which CDK checks ()https://github.com/redhat-developer/minishift/blob/master/pkg/minishift/openshift/version/openshift_versions.go#L176 if given OCP version is available is not working anymore.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  anjannath Anjan Nath
                  Reporter:
                  agajdosi Andreas Gajdosik
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: