Uploaded image for project: 'Artificer'
  1. Artificer
  2. ARTIF-505

maven:deploy CLI command missing maven.type property sometimes

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 0.5.0.Beta2
    • Component/s: Shell
    • Labels:
      None

      Description

      The maven:deploy s-ramp cli command does not currently set the maven.type property under all circumstances. A requirement is that maven.type always be set. Currently the CLI command gets this information from the arguments to the command. In some cases the user will not include the "type" information on the command line. In this case the type should be pulled from the file extension of the file being uploaded.

      If the file being uploaded does not have an extension and the maven.type is not provided as part of the GAV argument, then the command should fail.

      Note: the name of the artifact should also include the file's extension - this is currently being left off.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                virchete David virgil naranjo
                Reporter:
                eric.wittmann Eric Wittman
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: