Uploaded image for project: 'Artificer'
  1. Artificer
  2. ARTIF-408

Tab completion no longer works in s-ramp CLI

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 0.5.0.Alpha1
    • Component/s: None
    • Labels:
      None

      Description

      The recent change to using AESH has broken tab-completion. For example, I typed the following:

      s-ramp> conn
      

      Then I hit "tab" and I got this:

      s-ramp> connmp:connect
      

      And the cursor was placed three spaces beyond "connect". After that tab didn't work at all because the command wasn't recognized (obviously).

      If I type s-ramp:connect manually and then hit tab, I get this:

      s-ramp> s-ramp:connect t:8080/s-ramp-server
      

      Also tab-completion of just the namespace adds an extra space at the end. If I back up one and use tab, I get the list of commands in the namespace but it won't actually complete any of them.

      So I think there is some fundamental problem with the tab completion. I tested on Windows cygwin. I will now go test on Fedora.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                virchete David virgil naranjo
                Reporter:
                eric.wittmann Eric Wittman
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: